1. Avant de poster un sujet, vérifiez que vous êtes dans la bonne section ! Est-ce que le jeu se lance ? Est-ce qu'il crashe ? Est-ce que le launcher fonctionne comme attendu ? Ou est-ce un problème avec le site ? Ou avec Minecraft en général ? Toutes ces questions vous permettront de trouver la bonne catégorie ;)

Forge n'est pas pris en compte par mon launcher

Discussion dans 'Sujets résolus' démarrée par XFallSeane, 23 Juin 2017.

Statut:
Fermé aux futures réponses.
  1. XFallSeane

    XFallSeane Membre

    Inscrit depuis le :
    23 Juin 2017
    Messages :
    10
    "J'aime" reçus :
    0
    ID du launcher : #190289
    Est-il Premium : Non
    OS : Windows 10
    Version de Java : Java 8
    Version de Minecraft : 1.11.2
    Version de Forge : 1.11.2-forge1.11.2-13.20.0.2315

    Bonjour à tous, cela va faire maintenant quelques heures que je cherche sans résultats.. j'ai créer mon launcher, je l'es paramétrer, j'ai créer mon archive contenant :

    [​IMG]
    Le dossier versions contient :

    [​IMG]
    Hors le jeu ne se lance jamais en mode forge, je commence à désespérer.

    J'ai essayer en uploadant le .zip via l'option "envoyer un fichier .zip" en hébergeant moi même via mon site aucun des deux n'a changer quelque chose.

    Avez vous une idée sur la solution ?

    Merci d'avance.
     
  2. Apokalysme

    Apokalysme Modérateur et conseiller Membre de l'équipe

    Inscrit depuis le :
    18 Juin 2015
    Messages :
    1,488
    "J'aime" reçus :
    77
    Bonjour XFallSeane,
    Je vais faire quelques tests avec cette version de Forge.
    J'ai remarqué que lorsqu'ils faisaient des modifications dans la structure de leurs fichiers, la création de ZIP avait tendance à foirer.

    Je te fais un retour au plus vite.
    Cette partie du message a été fusionnée car un autre message a été posté à sa suite :
    Je crois que j'ai compris ce qui n'allait pas : la version de Forge, c'est "13.20.0.2315", pas "1.11.2-forge1.11.2-13.20.0.2315".
    Si dans le Générateur d'Archive Forge, on met "1.11.2-forge1.11.2-13.20.0.2315", il ne va pas reconnaitre correctement les fichiers de Forge.
    Par contre, avec juste "13.20.0.2315", il va créer l'archive correctement.

    Je l'ai créé et j'en ai profité pour l'ajouter dans le Tutoriel.

    Si tu as d'autres questions, n'hésite pas.
     
  3. XFallSeane

    XFallSeane Membre

    Inscrit depuis le :
    23 Juin 2017
    Messages :
    10
    "J'aime" reçus :
    0
    Le problème à été résolu avant t'a réponse, j'ai pu remarquer que mes versions n'avait pas été prise en compte dans le zip ! (Bizarre) mais j'ai réussie pour mon launcher de test. Mais néanmoins seul la version .jar fonctionne, l'autre demande une version de java que j'ai (même supérieure).
     
  4. Apokalysme

    Apokalysme Modérateur et conseiller Membre de l'équipe

    Inscrit depuis le :
    18 Juin 2015
    Messages :
    1,488
    "J'aime" reçus :
    77
    Pour le launcher JAR / EXE, c'est un point qui a déjà été remonté.
    Si tu veux un EXE utilisable, sur notre site, tu peux aller dans la partie "Outils" et utiliser le convertisseur JAR vers EXE.
    Il te suffira d'indiquer le JAR que tu as sur ton PC et d'indiquer la version de Java que tu as.
    L'EXE généré devrait être nickel.
     
  5. XFallSeane

    XFallSeane Membre

    Inscrit depuis le :
    23 Juin 2017
    Messages :
    10
    "J'aime" reçus :
    0
    Les problèmes sont résolu pour ma part.
     
  6. Apokalysme

    Apokalysme Modérateur et conseiller Membre de l'équipe

    Inscrit depuis le :
    18 Juin 2015
    Messages :
    1,488
    "J'aime" reçus :
    77
    Merci pour ton retour !

    Bon jeu à toi :)
    Je lock.
     
Statut:
Fermé aux futures réponses.

Partager cette page