1. Avant de poster un sujet, vérifiez que vous êtes dans la bonne section ! Est-ce que le jeu se lance ? Est-ce qu'il crashe ? Est-ce que le launcher fonctionne comme attendu ? Ou est-ce un problème avec le site ? Ou avec Minecraft en général ? Toutes ces questions vous permettront de trouver la bonne catégorie ;)

A lire ! Problèmes courants résolus

Discussion dans 'Aide avec un launcher (le jeu freeze ou crash)' démarrée par Apokalysme, 6 Août 2015.

Statut:
Fermé aux futures réponses.
  1. Apokalysme

    Apokalysme Modérateur et conseiller Membre de l'équipe

    Inscrit depuis le :
    18 Juin 2015
    Messages :
    1,488
    "J'aime" reçus :
    77
    Bonjour à tous,

    Avant de créer votre discussion, voici une liste des problèmes courant qui ont trouvé leur solution.
    Peut-être que vous pourrez vous épargner le temps de créer une discussion et d'attendre qu'on vous réponde en parcourant les paragraphes ci-dessous :

    1 - java.util.ConcurrentModificationException
    Voici le code d'erreur complet que vous pourriez rencontrer si jamais vous utilisez Forge :
    Code:
    [main/ERROR]: Unable to launch
    java.util.ConcurrentModificationException
    at java.util.ArrayList$Itr.checkForComodification(Unknown Source) ~[?:1.8.0_51]
    at java.util.ArrayList$Itr.remove(Unknown Source) ~[?:1.8.0_51]
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:117) [launchwrapper-1.9.jar:?]
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.9.jar:?]
    
    Voici quelques points à vérifier :
    • Conflit entre mods : Assurez-vous que les mods que vous avez intégrés n'ont pas de conflits sur un item, un enchantement, un bloc ou tout autre élément du jeu.
    • Version de Forge : Nous ne supportons que l'utilisation des versions stables dites "Recommended" du site de Forge.
      Si vous avez une version plus ancienne ou que vous tentez l'utilisation de la version dite "Latest", vous vous exposez à l'inattendu et aux bugs ... sur lesquels nous ne pouvons rien.
    • Compatibilité Minecraft <=> Java : Voici les versions de Minecraft qui fonctionnent en fonction des versions de Java :
      • Java 1.7 : Minecraft 1.6.4 / 1.7.2 / 1.7.10 / 1.8 / 1.8.8
      • Java 1.8 : Minecraft 1.7.10 / 1.8 / 1.8.8
      • Pour Java 1.8, les versions 1.6.4 et 1.7.2 peuvent fonctionner en intégrant le patch disponible sur MinecraftForum.
    2 - Could not reserve enough space for object heap
    Voici l'erreur que vous pourriez rencontrer (la valeur "1572864KB" est en exemple, vous pourriez avoir une valeur différente) :
    Code:
    Error occurred during initialization of VM
    Could not reserve enough space for 1572864KB object heap
    
    Dans ce cas, il vous faut vérifier votre RAM et l'argument "-Xmx".
    Si vous n'avez pas assez de RAM, réduisez la valeur que vous voulez configurer avec l'argument "-Xmx" sur le site LMC. Sinon, essayez de l'augmenter.
    Si malgré tout, vous avez toujours cette erreur, vous pouvez aussi essayer de réinstaller Java, en vous assurant de prendre la version 64bits.
    En dernier, si rien ne change, peut-être devrez-vous ajouter de la RAM dans votre PC.

    3 - java.lang.OutOfMemoryError: Java heap space
    Cette erreur indique que la valeur de l'argument personnalisé "-Xmx" n'est pas assez grand.
    Nous ne pouvons que vous suggérer de l'augmenter progressivement en partant de "-Xmx1G", en passant par "-Xmx1536M" jusqu'à "-Xmx2G".
    Vous pouvez indiquer une valeur plus grande si vous le souhaitez, mais veillez à ce que toutes les personnes à qui vous diffuserez le launcher ait la RAM suffisante.

    4 - ClassNotFoundException cpw.mods.fml.common.launcher.FMLTweaker
    Si vous trouvez le code d'erreur suivant :
    Code:
    [16:12:28] [main/ERROR]: Unable to launch
    java.lang.ClassNotFoundException: cpw.mods.fml.common.launcher.FMLTweaker
    at java.net.URLClassLoader.findClass(Unknown Source) ~[?:1.8.0_60]
    at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_60]
    at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source) ~[?:1.8.0_60]
    at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_60]
    at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:106) ~[launchwrapper-1.11.jar:?]
    at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_60]
    at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_60]
    at java.lang.Class.forName0(Native Method) ~[?:1.8.0_60]
    at java.lang.Class.forName(Unknown Source) ~[?:1.8.0_60]
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:98) [launchwrapper-1.11.jar:?]
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.11.jar:?]
    
    Voici quelques points à vérifier :
    • Version de Forge : Nous ne supportons que l'utilisation des versions stables dites "Recommended" du site de Forge.
      Si vous avez une version plus ancienne ou que vous tentez l'utilisation de la version dite "Latest", vous vous exposez à l'inattendu et aux bugs ... sur lesquels nous ne pouvons rien.
    • Vous ètes sous Linux / Mac : Une section est dédié plus bas.

    5 - Erreur OpenGL : pixel format not accelerated
    Il est possible que vous trouviez le code d'erreur suivant :
    Code:
    [13:25:35] [Client thread/ERROR]: Couldn't set pixel format
    org.lwjgl.LWJGLException: Pixel format not accelerated
            at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method) ~[lwjgl-2.9.1.jar:?]
            at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52) ~[lwjgl-2.9.1.jar:?]
            at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:252) ~[lwjgl-2.9.1.jar:?]
            at org.lwjgl.opengl.Display.createWindow(Display.java:306) ~[lwjgl-2.9.1.jar:?]
            at org.lwjgl.opengl.Display.create(Display.java:848) ~[lwjgl-2.9.1.jar:?]
            at org.lwjgl.opengl.Display.create(Display.java:757) ~[lwjgl-2.9.1.jar:?]
            at net.minecraftforge.client.ForgeHooksClient.createDisplay(ForgeHooksClient.java:327) ~[ForgeHooksClient.class:?]
            at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:432) [bao.class:?]
            at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:878) [bao.class:?]
            at net.minecraft.client.main.Main.main(SourceFile:148) [Main.class:?]
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_65]
            at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_65]
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_65]
            at java.lang.reflect.Method.invoke(Unknown Source) ~[?:1.8.0_65]
            at net.minecraft.launchwrapper.Launch.launch(Launch.java:135) [launchwrapper-1.11.jar:?]
            at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.11.jar:?]
    
    Si vous ètes sous Windows 10, malheureusement, il y a peu de chances que cette erreur trouve une solution.
    En effet, la plupart des cartes graphiques n'ont malheureusement pas vu leur Pilotes ("Driver") être mis à jour pour Windows 10.

    Dans ce cas, il n'y a pas de solution connue.
    Les seuls choix restant :
    • si vous avez mis à jour votre Windows en version 10 il y a moins de 30 jours, revenez en arrière sur votre Windows 7, 8 ou 8.1.
    • sinon, il sera nécessaire de racheter une carte graphique supportée ou un nouveau PC

    6- Si vous êtes sous Linux ou Mac OS avec "Erreur : impossible de trouver ou charger la classe principale net.minecraft.client.main.Main"
    Désolé, mais pour le moment, le launcher n'est pas stable avec ces Systèmes d'Exploitation et provoque l'erreur suivante au démarrage :
    Code:
    Erreur : impossible de trouver ou charger la classe principale net.minecraft.client.main.Main
    
    Le problème est ancien mais peine à trouver une solution.
    L'équipe continue de travailler sur ce problème et ne manquera pas d'informer les membres dans la section News si le problème venait à être résolu.


    Nous mettrons à jour ce Topic au fur et à mesure que des problèmes réapparaissent.
    J'espère que votre problème était bien dans la liste ci-dessus et que vous avez pu le résoudre.

    Sinon, n'hésitez pas à créer un Topic dans la catégorie adéquate pour nous demander de l'aide, en n'oubliant pas de nous fournir toutes les informations listées dans le
    Guide pour faire une demande d'aide.

    Apokalysme
     
    Dernière édition: 30 Novembre 2015
Statut:
Fermé aux futures réponses.

Partager cette page